Error registration VMWARE ova

I have tried to register 3 different ova templates via vmware. The first two would not connect at all and thinking it was a FW issue I just waited for FW team to track the logs. We got those fixed but now when I run the final steps i am left with ERROR: registering ziti

This is on Teams so maybe that is the limitation but wanted to test drive before purchasing.

Hi @musashi091

Welcome to the community! Glad you’re testing things out with the teams edition. If you don’t mind, can you provide the command you’re using to register & the entire output, just so we have a better understanding of the issue?

The usual reasons for the ziti registration failing, is if the registration key was already used, or is expired since it’s only valid for two days.

Hi Musashi091,

If you have FW at your location, please also make sure you turn off any deep packet inspection or proxy.


I think I figured out the issue. The VM has two NIC’s and the VM is getting confused once it goes to reach out. I found the Netfoundry videos , Skip explains exactly what to do so I am going to test that now.

Got much further but now the minion wont finish.

There are multiple ways which will cause minion registration failure.

First, can you tell me your network name?
Second, as I stated earlier, if you have a deep packet inspection or proxy setup on your network, ziti will not work. Which will also cause the minion registration to fail.



I got it all fixed. It was the network in vmware. Last question is for the link listener. Is that needed for it to be reachable outside the network? Or will it default be available already on 443?